Discussion:
[gem5-dev] Change in gem5/gem5[master]: systemc: Disable systemc when using gcc versions older than 5.0.
(too old to reply)
Gabe Black (Gerrit)
2018-11-30 01:36:34 UTC
Permalink
Gabe Black has uploaded this change for review. (
https://gem5-review.googlesource.com/c/public/gem5/+/14755


Change subject: systemc: Disable systemc when using gcc versions older than
5.0.
......................................................................

systemc: Disable systemc when using gcc versions older than 5.0.

These versions don't support the std::put_time function. Since versions
of gcc older than 5.0 aren't going to be supported at all in the fairly
near future, this should only be temporary. The number of people using
both systemc and older versions of gcc should be very small, or even
zero.

Change-Id: Ie9572fdf83ba9569df6bc0457c98d86565dcdcd8
---
M src/systemc/SConscript
1 file changed, 10 insertions(+), 0 deletions(-)



diff --git a/src/systemc/SConscript b/src/systemc/SConscript
index d3ead8c..694ee56 100644
--- a/src/systemc/SConscript
+++ b/src/systemc/SConscript
@@ -27,5 +27,15 @@

Import('*')

+from m5.util import compareVersions
+from m5.util.terminal import termcap
+
if env['USE_SYSTEMC']:
+ if compareVersions(env['GCC_VERSION'], '5.0') < 0:
+ print(termcap.Yellow + termcap.Bold +
+ 'Warning: Disabling systemc on gcc versions less than
5.0.' +
+ termcap.Normal)
+ env['USE_SYSTEMC'] = False
+ Return()
+
env.Append(CPPPATH=Dir('ext'))
--
To view, visit https://gem5-review.googlesource.com/c/public/gem5/+/14755
To unsubscribe, or for help writing mail filters, visit
https://gem5-review.googlesource.com/settings

Gerrit-Project: public/gem5
Gerrit-Branch: master
Gerrit-Change-Id: Ie9572fdf83ba9569df6bc0457c98d86565dcdcd8
Gerrit-Change-Number: 14755
Gerrit-PatchSet: 1
Gerrit-Owner: Gabe Black <***@google.com>
Gerrit-MessageType: newchange
Continue reading on narkive:
Loading...